505 Internal Server Error
Something has gone wrong at the server end of the call. Contact support for assistance and provide them with the details of the call parameters.
Possible causes:
- if retrieving a document from the document library, this error may result if the GUID of the item being retrieved is not found
- programmatic failure on the web server
400 Bad Request Error
If response detail is ‘invalid characters in new item key value’ then remove characters from key value and try again.
422 Unprocessable Entity
If response detail is ‘Item Name not passed’ then check the correct parameters have been used e.g. should it be ‘AssetCode’ instead of ‘AssetID’.
401 Unauthorised Error
You may be using an invalid user name or password as credentials.
404 Not found Error
Check the name of the procedure being called is correct e.g. there may be a typo like ‘Orderrs’ instead of ‘Orders’
403 Forbidden Error
The user being used in the credentials may not have the correct role to access the procedure being called. Check the roles the user has access to, and check the relevant role has the procedure being called. Note: if credentials are ok ask support to check that the database connector is running and responding to requests as any problems with that layer will appear as an “access not granted” error.